You cannot extend/create any logical volume of more than 2 TB in HP-UX LVM with VG version 1.0. Max is 2 TB and that too on 11.31 because the number of max physical extents (PE) on 11.31 is 65536 and with that max size of PE 32 MB. so total size= 65536*32 mb= 2 TB.
To create or extend a logical volume greater than 2TB you need VG Version 2.0. Here I have shown the process to create a logical volume of 3TB.
Scan Newly Added Disk
First, scan the newly exported disk from the storage using the command ioscan -fnNC disk
# ioscan -fnNC disk
Class I H/W Path Driver S/W State H/W Type Description
===================================================================
disk 3 64000/0xfa00/0x1 esdisk CLAIMED DEVICE HP Virtual LvDisk
/dev/disk/disk3 /dev/disk/disk3_p2 /dev/rdisk/disk3 /dev/rdisk/disk3_p2
/dev/disk/disk3_p1 /dev/disk/disk3_p3 /dev/rdisk/disk3_p1 /dev/rdisk/disk3_p3
disk 4 64000/0xfa00/0x7 esdisk CLAIMED DEVICE 3PARdataVV
/dev/disk/disk4 /dev/rdisk/disk4
disk 5 64000/0xfa00/0x8 esdisk CLAIMED DEVICE 3PARdataVV
/dev/disk/disk5 /dev/rdisk/disk5
disk 17 64000/0xfa00/0x2b esdisk CLAIMED DEVICE 3PARdataVV
/dev/disk/disk17 /dev/rdisk/disk17
Create Physical Volume
Create the physical volume using the command pvcreate. Physical volume “/dev/rdisk/disk17” has been successfully created.
# pvcreate /dev/rdisk/disk17 pvcreate: Warning: The physical volume "/dev/rdisk/disk17", is initialized to use only the first 2147483647KB of disk space in volume group version 1.0. On volume group version 2.x, the physical volume size will be recalculated to use full size upto a maximum of 17179869184KB. Physical volume "/dev/rdisk/disk17" has been successfully created.
Create Volume Group
Now create the volume group using the command vgcreate with the parameters given below. Here I have given VG name as vgrctest and after successful execution of the command Volume group “/dev/vgrctest” has been successfully created.
-V: vg version 2.0
-s : PE size (256 mb)
-S: max vg size 2 peta byte.
# vgcreate -V 2.0 -s 256 -S 2p /dev/vgrctest /dev/disk/disk17 Volume group "/dev/vgrctest" has been successfully created. Volume Group configuration for /dev/vgrctest has been saved in /etc/lvmconf/vgrctest.conf
Display Volume Group Information
Display the VG information of the newly created volume group named vgrctest using the command vgdisplay -v. Here you can see the details that show the information like PE size, Total PE, Free PE etc. This is a new volume group so all the 12287 PEs are free in this volume group.
# vgdisplay -v /dev/vgrctest --- Volume groups --- VG Name /dev/vgrctest VG Write Access read/write VG Status available Max LV 511 Cur LV 0 Open LV 0 Max PV 511 Cur PV 1 Act PV 1 Max PE per PV 65536 VGDA 2 PE Size (Mbytes) 256 Total PE 12287 Alloc PE 0 Free PE 12287 Total PVG 0 Total Spare PVs 0 Total Spare PVs in use 0 VG Version 2.0 VG Max Size 2p VG Max Extents 8388608 --- Physical volumes --- PV Name /dev/disk/disk17 PV Status available Total PE 12287 Free PE 12287 Autoswitch On Proactive Polling On
Create Logical Volume
Create the logical volume using the command lvcreate and give the no of PEs for which you want to create the logical volume. Here I have taken all PEs which are free. Logical volume “/dev/vgrctest/lvol1” has been successfully created.
# lvcreate -l 12287 /dev/vgrctest Logical volume "/dev/vgrctest/lvol1" has been successfully created with character device "/dev/vgrctest/rlvol1". Logical volume "/dev/vgrctest/lvol1" has been successfully extended. Volume Group configuration for /dev/vgrctest has been saved in /etc/lvmconf/vgrctest.conf
Format Raw Logical Volume
Format the raw logical volume using the command shown below.
# newfs -F vxfs -o largefiles /dev/vgrctest/rlvol1 version 7 layout 3220963328 sectors, 402620416 blocks of size 8192, log size 32768 blocks largefiles supported
Create Mount Point and Mount
Create the mount point directory and mount the formatted volume on the mount point directory.
# mkdir /rctest # mount /dev/vgrctest/lvol1 /rctest # bdf Filesystem kbytes used avail %used Mounted on /dev/vg00/lvol3 4194304 3727320 466984 89% / /dev/vg00/lvol4 10485760 8895680 1580536 85% /home /dev/vgrctest/lvol1 3220963328 362072 3195440320 0% /rctest
Related Posts
- How to Find NIC (Network Interface Card) Details in HP-UX
- How to Install a .depot Package Using swinstall on HP-UX
- HP-UX: How to restrict NFS share access to a particular server?
- crontab: you are not authorized to use cron. Sorry. in HP-UX
- HP-UX: SSH taking too much time after adding the DNS Servers
- How to add DNS servers on an HP-UX server
- How to login to vPar console in HP-UX
- How to extend the size of Logical Volume (LV) in HP-UX
- How to determine file system type in HP-UX using command
- How to check vPar machines status in HP-UX
- How to find HBA cards/ports and WWN Number details in HP-UX (nPar)
- How to find HBA cards/ports and WWN Number details in HP-UX (vPar)
- HP-UX command to get Physical Memory Information
- HP-UX command to get Processor Information
- HP-UX command to get Hardware Serial Number
- su: Sorry in HP-UX while switching from normal user to root user
- SSH login taking too much time on HP-UX 11.31
- How to Disable Root SHH Login in HP-UX?
- hpvmstatus: HPVM currently not running.
- How to view/print routing table in HP-UX?
- Create a Logical Volume larger than 2TB and format it in HP-UX
- Protect SSH Logins with SSH and MOTD Banner Messages in HP-UX
- Remove welcome message after login in HP-UX 11.31
- Create a Logical Volume and format it in HP-UX
- How to rescan new LUNs added in HP-UX 11.31
- How to reboot a HP-UX machine?
- How to remove File System, LV and VG in HP-UX and Linux?
- How to remove NO_HW devices from ioscan in HP-UX without a reboot?
- Change root user password of vpar machine in HP-UX