Problem
How to remove NO_HW devices from ioscan in HP-UX without a reboot?
Solution
You can remove the “NO_HW” devices from ioscan by using the command rmsf -k -H <hw_path> and there is no need to reboot the HP-UX system. I have done this on HP-UX 11.31. Follow the below process to remove the NO_HW devices:
Remove NO_HW Deices from HP-UX
- Run the below command to see all devices and identify the devices with NO_HW. Here disk16 is NO_HW device.
# ioscan -fnNC disk disk 5 64000/0xfa00/0x8 esdisk CLAIMED DEVICE 3PARdataVV /dev/disk/disk5 /dev/rdisk/disk5 disk 16 64000/0xfa00/0x2a esdisk NO_HW DEVICE 3PARdataVV /dev/disk/disk16 /dev/rdisk/disk16
- Now run the below command, where 64000/0xfa00/0x2a is the hardware path which is taken from the disk details shown above
# rmsf -k -H 64000/0xfa00/0x2a
- Again run the ioscan command to verify the removed devices. The below details show that NO_HW device has been removed.
# ioscan -fnNC disk disk 5 64000/0xfa00/0x8 esdisk CLAIMED DEVICE 3PARdataVV /dev/disk/disk5 /dev/rdisk/disk5
Now you can see that entry of “NO_HW” has been removed.
If you have lots of NO_HW entries, make a for-loop script that will automate for you.
Related Posts
- How to Find NIC (Network Interface Card) Details in HP-UX
- How to Install a .depot Package Using swinstall on HP-UX
- HP-UX: How to restrict NFS share access to a particular server?
- crontab: you are not authorized to use cron. Sorry. in HP-UX
- HP-UX: SSH taking too much time after adding the DNS Servers
- How to add DNS servers on an HP-UX server
- How to login to vPar console in HP-UX
- How to extend the size of Logical Volume (LV) in HP-UX
- How to determine file system type in HP-UX using command
- How to check vPar machines status in HP-UX
- How to find HBA cards/ports and WWN Number details in HP-UX (nPar)
- How to find HBA cards/ports and WWN Number details in HP-UX (vPar)
- HP-UX command to get Physical Memory Information
- HP-UX command to get Processor Information
- HP-UX command to get Hardware Serial Number
- su: Sorry in HP-UX while switching from normal user to root user
- SSH login taking too much time on HP-UX 11.31
- How to Disable Root SHH Login in HP-UX?
- hpvmstatus: HPVM currently not running.
- How to view/print routing table in HP-UX?
- Create a Logical Volume larger than 2TB and format it in HP-UX
- Protect SSH Logins with SSH and MOTD Banner Messages in HP-UX
- Remove welcome message after login in HP-UX 11.31
- Create a Logical Volume and format it in HP-UX
- How to rescan new LUNs added in HP-UX 11.31
- How to reboot a HP-UX machine?
- How to remove File System, LV and VG in HP-UX and Linux?
- How to remove NO_HW devices from ioscan in HP-UX without a reboot?
- Change root user password of vpar machine in HP-UX